Troubleshooting X-Windows

If the tool windows are not displayed on the submit host, this is caused by having set the incorrect value of DISPLAY or from not allowing remote hosts to connect.

You should use the xhost + command on the machine where the windows should appear so that the farm hosts are permitted to display there. If you do not wish to permit all hosts to connect, use xhost +farm-host-name for the desired hosts.

There is an option to the X-server -nolisten tcp that causes the X-server to only accept client connections from the local host. This option is typically used with the secure shell, ssh, that automatically sets the DISPLAY to localhost:NN and port-forwards the connection back to the host from which you logged in.

Linux distributions may ship with -nolisten tcp enabled by default. With this setting, jobs from farm hosts cannot connect.

To configure your X-server so that remote hosts can connect, re-start the X-server without the -nolisten tcp option. This action requires root access to your machine.

Note: If there is a security policy that prohibits non-tunneled X-windows protocol, executing this change may also require coordination with your IT department.
The following are instructions to configure the X-server on two platforms:
Red Hat Enterprise Linux
  1. Use the command gdmsetup as root.
  2. Uncheck Always disallow TCP connections to the X-server in the Security tab.
  3. Log out as root, then re-login as yourself.
SuSE 9.1 Pro Linux
A section in the file /etc/sysconfig/displaymanager that contains an envVar that controls whether remote clients are allowed to connect.
The following is the relevant section of the file:
## Type:        yesno
## Default:     no
# Tcp port 6000 of Xserver. When set to "no" (default) Xserver is 
# started with "-nolisten tcp". Only set this to "yes" if you really
# need to. Use ssh X11 port forwarding whenever possible.